SnapStream support for MPEG-2 playback

In order to support playback of MPEG-2 video, SnapStream uses a browser plugin (the "web player"). Browser plugins use a standard called NPAPI, which is not supported by all web browsers. This article documents the status of NPAPI support in major browsers as of January 1, 2018. 

PLEASE NOTE: The information on this page is subject to change without notice. 

Support for playback of H.264 video in all browsers is available in SnapStream version 8.0 and higher without the use of the SnapStream web player. For more information, see How are recordings played back in the SnapStream interface?

See also: How can I start recording H.264 video?

To schedule an update to the latest version of SnapStream, visit our page on youcanbook.me.

 

Microsoft Internet Explorer

Internet Explorer 11 includes support for NPAPI plugins. This is the final version of Internet Explorer, and plugins will continue to be supported as long as the browser is available. Note: the SnapStream web player is supported in the 32-bit version of Internet Explorer only. The 64-bit version of the browser will not load the web player. 

 

Safari

Apple has removed support for NPAPI plugins as of version 12.  To continue using Safari, you will need to use version 11 or earlier.

 

Mozilla Firefox

NPAPI plugins are disabled permanently as of version 52 of Firefox, which was released in March 2017. 

Support for NPAPI plugins is still available through the Firefox Extended Support Release (ESR) channel. This will continue to be the case until the last ESR 52 release, which is scheduled for May 2018. 

To switch from the main release channel to the ESR channel, simply download the installer for Windows or Mac. If you are using Windows, make sure to download the Windows version, NOT the Windows 64 version. When this installer is run, it will automatically overwrite the existing Firefox installation while preserving the user profile and all settings.

NOTE:  FireFox ESR 52 is now being updated to ESR version 60.  The links to the installers labelled Windows and Mac above still work as of 9/19/2018, but you will need to disable auto update to keep it from going to FireFox ESR 60.

 

Google Chrome

NPAPI plugins are disabled permanently as of version 45 of Chrome, which was released in September 2015.

 

Microsoft Edge

Edge does not support NPAPI plugins. 

Have more questions? Submit a request

0 Comments

Article is closed for comments.