Corrupted Closed Captions After Windows Update on SnapStream Encoder

Issue or Problem:

After running a Windows 10 update 1903 on your SnapStream Encoder, you may encounter recordings with closed caption text that appears garbled.

Cause:

This is due to an incompatible Intel Graphics Driver that interferes with the SnapStream Encoder's captioning functionality. The required driver is version 25.20.100.6323.

Solution:

To resolve this issue, please follow these steps or contact SnapStream support for assistance:

  1. Logon to the SnapStream Encoder desktop or via remote desktop.
  2. Download the compatible driver installer here: https://s3.amazonaws.com/download.snapstream.com/Intel%20Graphics%20for%20Encoders/win64_25.20.100.6323.exe
  3. Click the Windows button and type Services. Then click the Services app.
  4. Note the following steps will interrupt your streams to your SnapStream server: Select the SnapStream Broker service. Right-click and select Stop.
  5. Run the Intel Graphics Driver installer (win64_25.20.100.6323.exe).
  6. The installer may warn you that a newer driver is installed. Ignore that and proceed forward with the installation.
  7. Complete the installation. The Intel Graphics driver should now be version 25.20.100.6323. Note that the driver installer may require you to reboot the Encoder.
  8. If no reboot is requested, go to the Services window again, right-click the SnapStream Broker service and select Start.

Your new recordings should have correct closed caption text going forward.

Additional Notes:

Please contact SnapStream support for assistance in applying the driver update and configuring Windows to prevent future automatic driver updates. 

Applies to Version:

SnapStream Encoders running Microsoft Windows 10

Keywords:

Transcriptions closed-captions Windows update

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