Warning Notifications Stating, "lost communication with node".

Issue or Problem:


SnapStream Warning Notification reporting, "lost communication with node"


Cause:


This warning was designed to let someone know if one of the nodes in an Enterprise TV cluster has gone offline. 


Unfortunately, there is a known issue that can cause this warning to appear erroneously when a user clicks cancel on a clip that has already started being made.  This is because our software will tell the clipper to stop, but the clipper will ignore the request if it is already busy clipping.  This triggers our software to think that the node that is responsible for clipping has gone offline when it hasn't.  Th is circumstance will be fixed in a future version of our software.


Solution:


To verify that this is an erroneous warning that can be ignored, please follow the steps below.


  1. Browse to the SnapStream WebUI > Admin (at the top of the page) > Actions (on the left) > View Log.
  2. Search for, "deleted tasklist clipping".
  3. Look at the times of these user deleted TaskLists (examples below).
    NOTE: These messages are triggered any time a user clicks Cancel in one of the task popup notifications that appear in the bottom right corner of the SnapStream Web Interface after a user submits a clip to be created.

    5/5/2022 1:09:12 PM     Information     UserA deleted TaskList Clipping 12:58:34 pm - 1:06:25 pm

    5/5/2022 12:18:09 PM Information UserB deleted TaskList Clipping 12:05:00 pm - 12:15:46 pm

    5/5/2022 12:12:18 PM Information UserC deleted TaskList Clipping and ShowSqueezing 10:57:11 am - 11:04:38 am

    5/5/2022 12:11:06 PM Information UserD deleted TaskList Clipping 11:11:14 am - 11:16:48 am

    5/4/2022 3:24:58 PM     Information     dh43643 deleted TaskList Clipping Klein


  4. Compare the times above to the "lost communication with node" Warnings that were reported in your log (examples below).

    5/5/2022 1:09:42 PM     Error     NotifyEventInfo: Id=d8df4b01-914f-4836-845b-a5e6c1a8322c, Category=System, Source=System, Message="ServerName lost communication with node: ServerName"

    5/5/2022 12:18:54 PM Error NotifyEventInfo: Id=7ee79b79-a57b-4d11-a0b9-9c7575680a1d, Category=System, Source=System, Message="ServerName lost communication with node: ServerName"

    5/5/2022 12:12:49 PM Error NotifyEventInfo: Id=4058d904-4343-4d72-8243-acf0a16f96b2, Category=System, Source=System, Message="ServerName lost communication with node: ServerName"

    5/5/2022 12:11:37 PM Error NotifyEventInfo: Id=f9c15d19-430d-4529-a819-534e77c9f48f, Category=System, Source=System, Message="ServerNamelost communication with node: ServerName"

    5/4/2022 3:25:28 PM     Error     NotifyEventInfo: Id=addf2638-0821-4b8c-9c8b-cd49d587fc31, Category=System, Source=System, Message="ServerName lost communication with node: ServerName"


  5. If the warnings are within 30 seconds to a minute of the clip being cancelled, they can be safely ignored.


If this warning came from an Enterprise TV Cluster:  
NOTE:  None of this is applicable to SnapStream Cloud Systems or standalone SnapStream Servers.  Please keep in mind that SnapStream Encoders are not considered part of an Enterprise TV Cluster.


  1. Browse to the SnapStream WebUI > Admin (at the top of the page) > Machine (on the left under Settings).
  2. Select the drop down box for, "Machine", and look to see if there are any nodes in your SnapStream Cluster that are not appearing in the list.
    mceclip0.jpg
  3. Check to verify that the missing machine is powered on, connected to the network, and the SnapStream Broker Service is running on that system.


Additional Notes:


Enterprise Cluster users can check the status of the nodes in their cluster on the Admin tab (System Status), under the section called, "Connected Machines" when using SnapStream Software version 9.5 and above.


Applies to Version:


All Current SnapStream Software Versions


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