Issue or Problem:
After installing a new SSL certificate for the SnapStream System to use, the moments list and scrolling transcript stops populating during browser playback.
Cause:
This can happen if the new certificate isn't bound to ports 9190 and 9089.
Solution:
- From an administrative command prompt, run the command below.
netsh http show sslcert - Copy the Certificate Hash listed for 0.0.0.0:443, and confirm that another Certificate Hash is being used for 0.0.0.0:9190 and 127.0.0.1:9089.
- Set ports 9190 and 9089 to use the same certificate as 443 using the commands below.
NOTE: Replace CERT_THUMBPRINT in the commands below with the same Certificate Hash being used for 0.0.0.0:443 (copied in Step2).
netsh http delete sslcert ipport=127.0.0.1:9089
netsh http delete sslcert ipport=0.0.0.0:9190
netsh http add sslcert ipport=127.0.0.1:9089 certhash=CERT_THUMBPRINT appid={4ee09f08-1bad-40f0-8c53-e0f8ccbb0859}
netsh http add sslcert ipport=0.0.0.0:9190 certhash=CERT_THUMBPRINT appid={4ee09f08-1bad-40f0-8c53-e0f8ccbb0859}
Additional Notes:
Updating the SnapStream Software will also make these same changes for you.
Applies to Version:
This applies to versions 22.3 and above when a new SSL certificate has been implemented for IIS or IIS Express on the SnapStream System.